Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
Speed Drop after unquantifiable amount of time with ActionTec routers using wired ethernet
thecharris
Enthusiast

I've noticed some peculiar behavior with the routers that Verizon issues for FIOS customers using ethernet.  Normally I have a beaitiful 30mbs down, but after an underterminable amount of time this speed will drop to 2mbs and below and will not restore until I disable and renable the ethernet card.  I know for a fact this is a particular issue with Verizon issued routers because when I didn't have the television package I used a D-Link router that never had this behavior.  Also, I've noticed this only happens with one machine in particular (Windows 7 x64 bit, Realtek PCIE 1gig ethernet card) and have never had an issue with other systems using the router.

Does anyone have any insight on this issue?  Seems to be hardware related, specifically ethernet interface related.  Really frustrating.

0 Likes
Re: Speed Drop after unquantifiable amount of time with ActionTec routers using wired ethernet
Roadking10453
Contributor

I wonder if the router is getting swamped and its trying to slow the connection?

it's only 10/100 and if you're plugging a 1000 card in then *maybe* it gets cranky or just loses its mind?

I haven't seen that here but then again, I dont have a 1g port plugged in to the Westell either. I do have a netgear router wired in via a moca that has a 1gig port on it that I'm plugged in to w/a a 10/100/1000 laptop and no issues.

can you set the card in the PC for 100 instead of 1000?

Re: Speed Drop after unquantifiable amount of time with ActionTec routers using wired ethernet
smith6612
MVP MVP
MVP

Check to make sure the Realtek NIC is not negotiating 10Mbps Half Duplex over time. Also, update the drivers from Realtek's website if the version on your PC is older than that on Realtek's. You can check the driver version within the Device Manager in Windows 7 by viewing the card's properties.

Re: Speed Drop after unquantifiable amount of time with ActionTec routers using wired ethernet
thecharris
Enthusiast

Thanks guys, I'm going to try explicitely setting the card to 100 full duplex mode and see if that helps.  Looks like the drivers are up to date right now, see how it goes.

Re: Speed Drop after unquantifiable amount of time with ActionTec routers using wired ethernet
thecharris
Enthusiast

So far so good!

0 Likes
Re: Speed Drop after unquantifiable amount of time with ActionTec routers using wired ethernet
Roadking10453
Contributor

excellent! ('ve seen stuff similar in the old modem days where one or both ends would renegotiate to a lower speed for who knows what reason and I do recall some other systems have the same ability so I'm not surprised by this actually. And the other user coming in with a bunch of technospeak to sort us out certainly helped   😄