Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring the phone you love. OR get iPhone 13, on us. Online only. With Select 5G Unlimited plans. Extended for a limited time. Buy now
end of navigation menu
SidR
Enthusiast

UPnP used to work on my network. It's no longer working. None of my UPnP clients can see my PC (which is a UPnP server). I'm suspecting a router issue. Please help.

0 Likes
1 Solution

Correct answers
Re: UPnP
SidR
Enthusiast

Disabling IGMP fixed it.  Thanks.  Too bad Verizon's Live Chat couldn't fix it.

View solution in original post

Re: UPnP
smith6612
Super User
Super User

Just reset the router using the Pinhole on the back to get it back to factory defaults. That will get the Wi-Fi back since it resets the router back to the state in which you received it originally. From there, you'll want to try enabling UPnP in the router, and then disabling the IGMP proxy within the router. A quick search of this forum should be able to find the links to get to those settings in the router, but if you could tell us the make and model, along with revision of your router that would be appreciated.

Re: UPnP
SidR
Enthusiast

Disabling IGMP fixed it.  Thanks.  Too bad Verizon's Live Chat couldn't fix it.

Re: UPnP
smith6612
Super User
Super User

You're welcome. Enjoy!

Also a fun fact: If you have an ActionTec MI424WR Rev. F or newer, make sure it's set for WPA2 encryption (though anything lesser I would set it to there anyways for security sake). You'll get some higher speeds on the Wi-Fi if it's currently set to WPA or WEP only.

Re: UPnP
SidR
Enthusiast

Yes I recently replaced my router and got the Rev F.  I changed the security to WPA2 and now I'm getting faster WiFi speeds too.  Thanks again!

Re: UPnP
Hammerhead641
Enthusiast

I have the same problem. None of my network devices see my NAS which is a UPnP:AV server. This had been working for the last 2 months and just stopped.

0 Likes