Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring the phone you love. OR get iPhone 13, on us. Online only. With Select 5G Unlimited plans. Ends 1.31. Buy now
end of navigation menu
Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet
using-webmail
Newbie

Although I defintely do have internet access, I noticed that in System Preferences/Network, although the W-Fi status is "On" this statement is below: "Wi-Fi has the self-assigned IP address 192.168.1.46 and will not be able to connect to the Internet." There is a yellow dot preceding the "Wi-Fi / Self-Assigned IP" icon on the far left of the System Preferences/ Network window. The Network Diagnostics shows all the items under Network Status as green. I have the original Westell 6100F modem provided by Verizon in 2008. Is this statement: “Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet" still a problem that needs correcting? Thank you.

I have OS X Mavericks (10.9.5) and an Airport Time Capsule purchased in 2014.

0 Likes
1 Solution

Correct answers
Re: Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet
smith6612
Super User
Super User

A 192.168.xxx.xxx address is usually not self assigned. Self assigned would be 169.254.xxx.xxx addresses, which appear if a computer could not complete DHCP. It could mean that the computer is not using DHCP, but is instead set up with a Static IP in this case.

Check to make sure DHCP is enabled by going to System Preferences > Network > select Wi-Fi / Airport > select Advanced. From here, select TCP/IP, and make sure "Confgure IPv4" and "Configure IPV6" are set to "Use DHCP" and "Use Automatically" repsectively. Then, go to the DNS tab. Clear out any servers you see here by selecting their IP Addresses and clicking the Minus sign.

When you save these settings, your computer should be able to get online again.

By the way, since OS X Mountain Lion has reached End of Support for software and security updates, you may want to upgrade the system to OS X El Capitan when you have a chance. It's free via the App Store.

View solution in original post

Re: Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet
smith6612
Super User
Super User

A 192.168.xxx.xxx address is usually not self assigned. Self assigned would be 169.254.xxx.xxx addresses, which appear if a computer could not complete DHCP. It could mean that the computer is not using DHCP, but is instead set up with a Static IP in this case.

Check to make sure DHCP is enabled by going to System Preferences > Network > select Wi-Fi / Airport > select Advanced. From here, select TCP/IP, and make sure "Confgure IPv4" and "Configure IPV6" are set to "Use DHCP" and "Use Automatically" repsectively. Then, go to the DNS tab. Clear out any servers you see here by selecting their IP Addresses and clicking the Minus sign.

When you save these settings, your computer should be able to get online again.

By the way, since OS X Mountain Lion has reached End of Support for software and security updates, you may want to upgrade the system to OS X El Capitan when you have a chance. It's free via the App Store.

Re: Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet
using-webmail
Newbie

Smith6612 wrote: 

Check to make sure DHCP is enabled by going to System Preferences > Network > select Wi-Fi / Airport > select Advanced. From here, select TCP/IP, and make sure "Configure IPV6"...set to "Use Automatically"... Then, go to the DNS tab. Clear out any servers you see here by selecting their IP Addresses and clicking the Minus sign.

By the way, since OS X Mountain Lion has reached End of Support for software and security updates, you may want to upgrade the system to OS X El Capitan when you have a chance. It's free via the App Store.


Thanks so much. By the way, I have Mavericks OS 10.9.5.

This was the window before before I tried your suggestion.

 image

"Configure IPV6" was set to "Link-local".

In the DNS tab. The Minus sign was not available .

This is the window now.

image

0 Likes
Re: Wi-Fi has the self-assigned IP address... & will not be able to connect to the Internet
smith6612
Super User
Super User

Looks great now. You should be all set 🙂 Glad that helped.

0 Likes