Galaxy Nexus taking 1hr+ to send picture text
piccolabella
Newbie

I've noticed recently that my Nexus can take AGES to send a photo text... As I type this I've been waiting an hour or more for it to send, it just sits there saying "sending" under the text.  Anyone else have this issue or know of a way to fix it?

0 Likes
Reply
1 Solution
HoosierPop
Enthusiast - Level 3

Are you connected to wireless?  Pictures won't send unless you're using a data connection.  Had the same problem myself until I turned off wireless.  Hope this works for you.

View solution in original post

0 Likes
Reply
13 Replies
HoosierPop
Enthusiast - Level 3

Are you connected to wireless?  Pictures won't send unless you're using a data connection.  Had the same problem myself until I turned off wireless.  Hope this works for you.

0 Likes
Reply
piccolabella
Newbie

Wow, that worked.  That seems like a major flaw in the phone if you ask me.  Thanks for your quick reply.

0 Likes
Reply
Ann154
Community Leader
Community Leader

It isn't a flaw.  The phone is working as designed.  The MMS messages will only transfer over the Verizon Wireless network.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Reply
k2r
Enthusiast - Level 2

I think it's a flaw. Just because I can access wifi shouldn't turn off my ability to access the verizon connection.  If I'm able to send texts or make calls then I should be able to use the data as needed to send the pictures as well.  It's not like they put it in instructions that wifi must be turned off (not that they hand out instruction books anymore).

0 Likes
Reply
msturgis
Contributor - Level 3

Ann, you are grossly misinformed. All Verizon 3G / 4G smartphones while connected to wi-fi network AUTOMATICALLY initiate mobile data connection (unless mobile data is manually deactivated) to send MMS. That is exactly how it works on all my smartphones and thousands that I have come across.

0 Likes
Reply
HoosierPop
Enthusiast - Level 3

I thought the point of using wireless was to save on data.  Therefore, I always turn off data when using wireless so that I have absolute control over data.  I understand what you're saying that the data connection should automatically kick in when there is a requirement for it.  My thought is that if both are on, then how do I know which one is connnected.  Just saying....

msturgis
Contributor - Level 3

So, if you *MANUALLY* turned off/deactivated data, turning the wifi off was NOT the solution to your "picture not sending" problem - activating mobile data was the solution.

Like I said, if you hadn't manually deactivated mobile data, MMS would automatically use mobile data even when connected to wifi.

When the phone is connected to a wi-fi spot, as well as mobile data, wi-fi takes over and mobile data connection goes to dormant state (still connected but not actively transmitting). At this point, you won't even see the data indicator (4G/3G symbol) and all data transmission is done over the wifi. If the phone needs to do something that can ONLY be done over mobile data (such as sending/receiving MMS, checking for software updates on some handsets etc), it will initiate that and use that network instead.

Btw, data usage to send/receive MMS does not count towards your monthly data allowance.

0 Likes
Reply
Ann154
Community Leader
Community Leader

msturgis wrote:

Ann, you are grossly misinformed. All Verizon 3G / 4G smartphones while connected to wi-fi network AUTOMATICALLY initiate mobile data connection (unless mobile data is manually deactivated) to send MMS. That is exactly how it works on all my smartphones and thousands that I have come across.

Ah, but you agree that it only transfers through the Verizon Wireless data network. The MMS messages don't go through the WIFI network.

Do you know if the OP keeps their data connection on in dormant mode while using wifi? I don't know. I do know that like HoosierPop, I turn off my data connection when I plan to be connected to a wifi network for long periods of time. I also know that if set incorrectly, the WiFi sleep policy will also turn off the WiFi radio when the phone is inactive. This will cause the cellular data connection to become active again if the user left the data connection on all the time. This could lead to tons of data being transferred in the middle of the night while the user was asleepfor iinstance. With more and more people moving to tiered data plans how and when you use the cellular data connection becomes more important when the user has to watch their usage.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

msturgis
Contributor - Level 3

Yes, at this time MMS only go through mobile data network, not just "Verizon Wireless data network", as MMS go through while roaming also.

The part that you were incorrect about was suggesting that "Wi-Fi needs to be off for an MMS to go through and that is how the phone is designed". But that is NOT the solution. The requirement is that mobile data needs to be on, regardless of wi-fi being on or off. And THAT'S the proper suggestion.

I DO NOT need to know what the OP does with his Wi-Fi or mobile data connection - because it SIMPLY doesn't matter what the state of each connection is, the only thing that matters is if the mobile data is on for an MMS to go through. Mobile data connection DOES NOT depend on the state of Wi-FI connectivity. If mobile data is turned off manually, turning just the Wi-Fi off is not going to automatically turn it back on. And that is the reason the precise suggestion should have been "make sure your data connection is on", NOT "turn your wi-fi off".

0 Likes
Reply
piccolabella
Newbie

if this is the case then why is it that my phone still won't send the picture text with mobile data on and wifi enabled?

0 Likes
Reply
msturgis
Contributor - Level 3

That could be the "major flaw" like you suspected but refuted by Ann saying "It isn't a flaw. The phone is working as designed".

If it is designed to work this way, then you are right, it's a "design flaw".

If it is NOT designed to work this way but that's how it works, then is an flaw in the implementation of that design.

The truth is Verizon Galaxy Nexus is one of the worst rated garbage when it comes to connectivity, specially with the newest update. Nexus has known issues with transitioning among networks. No wonder the newest Nexus ditched LTE all together.

0 Likes
Reply
Ann154
Community Leader
Community Leader

I never wrote that the WiFi radio had to be turned off in this discussion.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

0 Likes
Reply
msturgis
Contributor - Level 3

Yes you didn't, that's why I wrote you "suggested".

HoosierPop wrote that turning WiFi off was what he had to do for the MMS to go through. OP thought it had to have been a design flaw, but you said it wasn't because the phone was just doing what it was designed to do, suggesting Wi-Fi needed to be turned off.

0 Likes
Reply