Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
Sim Card Contacts Import Issue
Smithpspfan
Enthusiast

Does the SIM card show as an option to import contacts from on the Samsung Galaxy S8? It does not show as an option on mine and it has me wondering if I have a bad phone or not because of this.

Tags (1)
0 Likes
1 Solution

Correct answers
Re: Sim Card Contacts Import Issue
deloused
Master

If you insert a compatible SIM card that has contacts stored on it the option to import from it should show with these steps-

  1. Tap Contacts Contacts icon.
  2. Tap the Menu icon More icon (located in the upper-right).
  3. Tap Manage Contacts.
  4. Tap Import/Export contacts.
  5. Tap Import.

Did you insert an older SIM card that you had used on another device that had contacts stored on it, or were you trying to do something else?

View solution in original post

0 Likes
Re: Sim Card Contacts Import Issue
deloused
Master

If you insert a compatible SIM card that has contacts stored on it the option to import from it should show with these steps-

  1. Tap Contacts Contacts icon.
  2. Tap the Menu icon More icon (located in the upper-right).
  3. Tap Manage Contacts.
  4. Tap Import/Export contacts.
  5. Tap Import.

Did you insert an older SIM card that you had used on another device that had contacts stored on it, or were you trying to do something else?

0 Likes
Re: Sim Card Contacts Import Issue
bearone21
Legend

you might have to import as an outlook or csv file.