Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
Where is the "Advanced Network Switch" on the S8+?
djfox1963
Newbie

I have wi-fi calling enabled on my Galaxy S8+ because the building I work in has horrible cell service.  I have no trouble enabling wi-fi calling and it works fine, but every time I walk into my building I get a prompt to "tap here to enable wi-fi calling" and I have to manually enable it on the phone.  I want it to auto-enable when my phone detects my employer's wireless network.  According to the Samsung Galaxy S8/S*+ manual, this is done by enabling the "Advanced Network Switch" via these instructions:

1. From a Home screen, navigate:Settings Settings icon > Connections Connections settings icon > Wi-Fi.

2. Ensure the Wi-Fi switch is turned on Switch On icon then tap the Menu icon Action overflow icon.

3. Tap Advanced.

4. Tap the Smart network switch to turn on Switch On icon or off Switch Off icon.

I get to step 3 - tap Advanced - and I see NO "Advanced Network Switch" option...checked with a colleague who just got a Galaxy S9 - he doesn't have an option for an "Advanced Network Switch" either. 

What gives?  And how do I auto-enable wi-fi calling without the Advanced Network Switch option? 

Thanks in advance for any suggestions. 

Tags (1)
0 Likes
Re: Where is the "Advanced Network Switch" on the S8+?
vzw_customer_support
Customer Support

Wi-Fi calling is a great feature and we do want to make sure that it works for you like it should, djfox1963.  Normally the Wi-Fi calling should remain activated and connect automatically when signal drops below a certain threshold.  Has this ever worked properly or is this the first time setting this feature up? You mentioned that your colleague has an S9 device.  Is he also experiencing the same difficulties with having to reconnect or re-enable the Wi-Fi calling feature?  What software version do you currently have on your device?

 

 

Adam_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes
Re: Where is the "Advanced Network Switch" on the S8+?
djfox1963
Newbie

Thanks for the response, Adam.

Here's what I and my colleague with an S9 are experiencing...we set up Wi-Fi call on our phones, click save, and everything works fine.  If we leave our building to go to lunch, when we come back, both our phones prompt with a box that says "Please click save to enable wi-fi calling" (or words to that effect).

Neither my Galaxy S8+ or my colleague's S9 are auto-switching to Wi-fi calling when the cell service drops (we work in the bottom floor of a brick building with very little cellular service).

I found these instructions, and they mention enabling a "Smart Network Switch" - but neither I or my colleague have an option to enable a "Smart Network Switch" on our phones:

Auto Switch Between Wi-Fi & Mobile Data Networks - Samsung Galaxy S8 / S8+ | Verizon Wireless

Are there updated instructions somewhere to enable auto-switching between Cellular and Wi-Fi networks?

Thank you.

0 Likes
Re: Where is the "Advanced Network Switch" on the S8+?
vzw_customer_support
Customer Support

I want to make sure that we are all on the same page here. In regards to smart network switch, your device does do that naturally. You don't have to turn on a particular setting in order for this to take place. Wifi calling is a different story.This feature does not auto connect. You will have to manually switch it each time you want to use it. Does this help?

Nichole_VZW
Follow us on TWITTER @VZWSupport
If my response answered your question please click the _Correct Answer_ button under my response. This ensures others can benefit from our conversation. Thanks in advance for your help with this!!

0 Likes