Skip to main content
Accessibility Resource Center Skip to main content
Get up to $500 when you bring the phone you love. OR get iPhone 13, on us. Online only. With Select 5G Unlimited plans. Ends 1.31. Buy now
end of navigation menu
Audio Issues (Picture / No Sound)
mfc172
Enthusiast

hopefully someone can help...

i have a Sharp TV, Vizio Soundbar and my set top box. All audio is output through the Vizio soundbar.  My TV is connected to the set top box via HDMI. TV is connected to soundbar via digital optical cable. 

My issue is that when i turn on my tv, cable box and soundbar (in any order), i get picture but no audio on cable. The picture flashes to a black screen once every 5-6 seconds or so for about a second. if i were to watch netflix or plex or any non-cable box show, the audio works just fine.

the only way ive found to correct this problem is to literally unplug and immediately plug back in the HDMI cable in the back of my cable box. I had thought it was clearly an issue with the HDMI cable, but ive swapped them out multiple times and the issue persists.

its annoying to pull out the cable box and unplug / plug in the HDMI cord every time i want to watch cable.

please tell me theres a fix for this. 

0 Likes
1 Solution

Correct answers
Re: Audio Issues (Picture / No Sound)
Telcoguru
Master

With the TV and cable box turned on press the STB button then the OK button then the Menu button on your remote contol in order with a slight pause between each press of the button. You should now be at user settings. Move down to Additional HDMI Settings and open it up. Move to the audio output and see if L-PCM  or Pass Through help you to get sound.

View solution in original post

Re: Audio Issues (Picture / No Sound)
SinCara
Specialist

The picture flashing is what's known as a hand shake issue. Google it.

How old is the tv?

0 Likes
Re: Audio Issues (Picture / No Sound)
Telcoguru
Master

With the TV and cable box turned on press the STB button then the OK button then the Menu button on your remote contol in order with a slight pause between each press of the button. You should now be at user settings. Move down to Additional HDMI Settings and open it up. Move to the audio output and see if L-PCM  or Pass Through help you to get sound.

Re: Audio Issues (Picture / No Sound)
mfc172
Enthusiast

Sharp Aquos LC70LE847U

0 Likes
Re: Audio Issues (Picture / No Sound)
mfc172
Enthusiast

thanks for this. 

all i can add is that i have the 7232 box.

in order to access that 'hidden' menu, the tv and cable box need to be on. then hit the power button and ok button on the STB and then hit the menu button on the remote. 

that gets you to the menu....

as of now, it seems to be working just fine. i will update if any issues arise...

thanks again.

0 Likes
Re: Audio Issues (Picture / No Sound)
Telcoguru
Master

Your welcome. Glad it is working.

0 Likes
Re: Audio Issues (Picture / No Sound)
Frostyvee
Newbie

I guess they took out additional HDMI settings. Just got the box today... HD picture. No sound...

0 Likes
Re: Audio Issues (Picture / No Sound)
CRobGauth
Super User
Super User

What model box and STB?

If quantum and Sony, there is already a thread about issues people are seeing.

0 Likes
Re: Audio Issues (Picture / No Sound)
kh-gary
Moderator
Moderator

In order to keep discussion on the community current, this topic has been locked to prevent new replies. If you have a similar question or issue that you wish to discuss, then please feel free to post a new message on the most relevant board. Thanks!

0 Likes