Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
Red snow over picture but menus and info bar are perfect
MidnightSon
Newbie

I've been through all the phone menu prompts - reboots and tests many times without a result.  Finally got through to an an agent on chat; after many more tests and reboots she claims the box is fine, problem has to be the HDMI cable.  Not that easy for me to change because TV is wall mounted with hidden cables.  Before I even waste money on a new cable, is it even possible that it's the cable when only the picture is affected; all the menus and the info ribbon at the bottom of the screen are perfect?

0 Likes
Re: Red snow over picture but menus and info bar are perfect
clem21
MVP MVP
MVP

@MidnightSon wrote:

I've been through all the phone menu prompts - reboots and tests many times without a result.  Finally got through to an an agent on chat; after many more tests and reboots she claims the box is fine, problem has to be the HDMI cable.  Not that easy for me to change because TV is wall mounted with hidden cables.  Before I even waste money on a new cable, is it even possible that it's the cable when only the picture is affected; all the menus and the info ribbon at the bottom of the screen are perfect?


If the menu and info bar are generated by the Fios box and look normal on your TV then the HDMI cable is most likely ok. Do you have any other sources you can check the cable with? Also are you looking at 1080i or 2160p? It's possible the cable is ok for 1080i, but is not able to properly pass 2160p.

0 Likes