A problem with a Mifi 2200 card. Please help!

Hey everyone. I came here to get help with my verizon mifi card that all the sudden after such a great run stops working!

I had bought two mifi 2200 cards at the same time about a year ago. All I did was turn them on and was getting Internet connection wirelessly to my ipad right away. My connection worked for ages and never had a problem until recently. One of the cards stopped working roughly about three months ago. I looked around online for things that perhaps was stopping the device from working. I figured that the device was ready for an update and that was prohibiting the device from working, but here is the weird part; the other card (the exact same one) was working when this first card I mentioned wasn't. The card working continued to work until just recently like a day or so ago. Odd right. Anyway, the first card I connected to the USB cord that was provided in the box into my laptop. I was immediatly prompted to download Verizon Manager. My first time ever getting to this step. I was connected to my Internet connection at home via LAN line because that was my only option to Internet. After the software was downloaded, I was prompted to update firmware in which I did, then I was told to update wifi area coverage information which is just that search for finding local wifi spots, the next one is the important one that never seemed to work. The message read somewhere along the lines of you need to update coverage area information as if in there was some new program via coverage to get the stuff to communicate with the device. I said yes and then a message popped up saying Activation and had this bar going side to side, but after a while was told the programming failed. The device has already been activated so I don't understand the reason for the word Activation. Regardless, I tried doing other things I've read on this forum like resetting the device, turning standby mode to never, and so forth, but none worked. The device powers on/everything is on, and I can connect to the device, but I have no Internet. Please, some one tell me what is going on.

Thank you and hope to hear from you soon.

2 Replies
Enthusiast - Level 2

mifi2200 take the battery out. wait just a few minutes, 10 should be enough put battery back in. Disconnect the hot spot from the usb cable. Boot up the modem make shore you LAN is connected. The icon in system tray. Put in the browser address bar hit enter. You will come to an admin page. Log in if you need the password default was admin.

There is a signal strength meter top red bar. you can administer you WWAN connection from there.

Not applicable

Hello strmchsr,

Thank you for sharing your issue with the community. We certainly want to resolve this as quickly as possible. I understand you must be frustrated. I would like to ask you a couple of questions to better understand your concerns.

  • What specific error message are you receiving on the iPad?
  • Have you been able to connect the Mifi 2200 to another device such as a laptop or computer?
  • If so what were the results? If not I have included some troubleshooting steps below.

I recommend trying to activate the Mifi 2200 on a windows based pc using the usb cable that came with the device. http://vzam.net/

The recommendation to remove the battery while the device is powered on is a great option, as ttb_62 suggested.

As a final option you can perform a hard reset provided that you have the original sticker from the Mifi 2200, which will include default password and the MEID number. I have included a link below to assist you.

Hard Reset:


Once you have tried these steps please retest your data service for functionality. If the issues persist please advise us and we will provide additional assistance.




VZW Support

Follow Us on Twitter@VZWSupport