Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
***Announcement: Early next week, we’ll be merging the current Fios and Wireless Communities into the all new Verizon Community! Beginning the evening of Sunday 12/4, both Communities will be placed in read-only mode. You’ll still be able to visit the Communities and browse content, but login will be disabled. On the afternoon of Monday 12/5, all users will be able to log into the new Verizon Community. We expect the new Community to be fully functional the morning of Friday 12/9. Additional details can be found in the Announcements board and under Featured Topics!
A problem with my mifi 2200 need help please
strmchsr
Member

Hey everyone. I came here to get help with my verizon mifi card that all the sudden after such a great run stops working!

I had bought two mifi 2200 cards at the same time about a year ago. All I did was turn them on and was getting Internet connection wirelessly to my ipad right away. My connection worked for ages and never had a problem until recently. One of the cards stopped working roughly about three months ago. I looked around online for things that perhaps was stopping the device from working. I figured that the device was ready for an update and that was prohibiting the device from working, but here is the weird part; the other card (the exact same one) was working when this first card I mentioned wasn't. The card working continued to work until just recently like a day or so ago. Odd right. Anyway, the first card I connected to the USB cord that was provided in the box into my laptop. I was immediatly prompted to download Verizon Manager. My first time ever getting to this step. I was connected to my Internet connection at home via LAN line because that was my only option to Internet. After the software was downloaded, I was prompted to update firmware in which I did, then I was told to update wifi area coverage information which is just that search for finding local wifi spots, the next one is the important one that never seemed to work. The message read somewhere along the lines of you need to update coverage area information as if in there was some new program via coverage to get the stuff to communicate with the device. I said yes and then a message popped up saying Activation and had this bar going side to side, but after a while was told the programming failed. The device has already been activated so I don't understand the reason for the word Activation. Regardless, I tried doing other things I've read on this forum like resetting the device, turning standby mode to never, and so forth, but none worked. The device powers on/everything is on, and I can connect to the device, but I have no Internet. Please, some one tell me what is going on.

Thank you and hope to hear from you soon.

0 Likes
Re: A problem with my mifi 2200 need help please
John_Getzke
Community Leader
Community Leader

Sounds like you botched a firmware update and bricked your MiFi.

Have you tried contacting VZW for a replacement device yet?

0 Likes