Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
MiFi won't download whole files or stream anymore
EvilMonkey
Newbie

I've used our MiFi's (from the company) for quite some time while traveling to download files or stream a movie from Netflix.  I don't know the exact model since it doesn't say, but it is a 4G LTE one.

This trip I am having issues where movies won't buffer more than 3 to 5 minutes (then will never continue even after hitting the end of the buffer), and similarly, I have tried downloading several larger files and the download will just stop part of the way through (for example, on a 300MB file, it will download about 175MB give-or-take then just stop and I cannot get it to continue).  I know my connection is still active, but things are don't seem to be working right.

My connection here according to Speedtest.net is over 10Mbps.

I have tried 2 different MiFi's (same model), 2 separate computers, disabled antivirus and firewall, ran a tracert to Netflix and a couple other streaming sites (such as Crackle) and the sites I'm attempting to download a file from.  I am relatively confident it's nothing on mine or the site's end....especially since it does start streaming or downloading fine, but then just cuts off.

Has Verizon changed something with how these work that it's cutting off larger downloads or streaming?

0 Likes
Re: MiFi won't download whole files or stream anymore
John_Getzke
Champion

What you describe sounds like a location specific problem.  Packets of information are most likely getting lost in the air which is breaking your connection to NetFlix.  I'd bet if you tried watching your content a ways down the road you would have better results.

If this was only happening on one MiFi/Computer I would suggest the resets that come along with the MiFi.  However, since multiple MiFi's and computers are having the same problem I'd doubt anything we do to the MiFi would be effective.

0 Likes