UML 295 hardware issue.

Hey everybody,

I just upgraded from an Asus Motherboard/AMD Phenom 2 x4 955 to an MSI Z87-G41 PC Mate/Haswell i5-4670K Combo.  So far I've been having 2 issues.

First:  My Verizon Pantech UML295 4G modem will not install drivers properly no matter what I do.  To make it more interesting, I installed Verizon Mobile Broadband Manager software, and it detects bars of signal, meaning it is using the modem and connecting with it, but nothing else can access the internet.  Under Windows device manager I don't see the modem, but rather an unidentified device.  I can't install other drivers, they're built into the modem which I can't access that I'm aware of to manually install them.  The Verizon tech just sent me to and then said "good luck", which was obviously less than helpful.  I've tried doing a fresh install on my main hard drive of Win 7 64bit but that didn't help at all.  So far I've only used the MSI drivers from the included disk for the motherboard.

Second:  Since install of the mobo/cpu combo (using same ram I had before GSkill Ripjaws 8Gb (2x4Gb) 240 pin DDR3 1600), most functions associated with Windows Explorer are running slow and randomly unresponsive.  Windows Media Player is always unresponsive for instance, and start up occasionally hangs past the windows boot screen on the black screen with a cursor.  I can play Hearts, and installed VLC Media Player and can play some movies from my secondary hard drive just fine.

Just to check, I reinstalled my old Asus mobo/AMD Cpu, and everything works fine now, so I know my modem and Win 7 install are fine and working.  Except that I have a 350 dollar paperweight on my desk in an attractive box.

I know a lot about computers, but I'm not an IT person, so I'm at a loss here.  I can't RMA the motherboard at this point, and I'd like to avoid getting a different one.  Can someone help me figure this out?

Re: UML 295 hardware issue.
Enthusiast - Level 2

I'm having a similar issue. I'm running a Lenovo Yoga convertible laptop with Windows 8 Professional. When using the UML295, all of my applications run extremely slow. I can't even launch my Global Sonicwall VPN client software. Many windows I open go into the (Not Responding) mode and freeze up. Interestingly enough, as soon as I unplug the UML295, all frozen applications unfreeze and my Sonicwall VPN software opens right up (assuming I've tried launching it with the UML295 still attached). Through all of this though, I am able to connect to the Verizon network (3G and 4G where available).

However, when I attached the UML295 to another laptop running Windows 7, it doesn't seem to have any issues running the same applications. I do have trouble connectiong to my VPN but at least the program itself will launch and attempt to connect.

If anyone has any suggestions on how to improve performance with Windows 8 and the UML295, please post your comments. I'm running out of options. Thank you!!