Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
Showing results for 
Search instead for 
Did you mean: 
Camera stopped focusing -- help?

I've had my Droid Charge for a little over a year.  A little while (~6 weeks?), the camera stopped focusing.  It is locked in closest possible focus.  My guess would be it's locked in macro mode, switching between macro, and face-focus, and autofocus makes no difference.  Touching a place on the picture to ask the camera to focus there has no effect.

I installed Ultra Magnifier a while ago, and wonder if it somehow screwed up a setting.  Uninstalling it hasn't changed anything, so don't know whether the camera problem is related to Ultra Magnifier or not. 

I don't use the camera a lot, so at first assumed this was just one of those temporary glitches that I commonly have with my phone (like it will lock up, or refuse to answer, or something).  Can't tie the problem to any other event (like installing a particular app).

Re-setting the phone, then setting it up again, is more of a hassle then I'm willing to put up with just to get the camera to work.  I have other pocket cameras that always take better pictures than my phone anyway.


<<  Discussion of rooting removed as a violation of >>

Message was edited by: Verizon Moderator

Tags (3)
Re: Camera stopped focusing -- help?

have you tried other camera apps?  I like Camera ICS for example.

also, perhaps that Ultra Maginifer app needs to be re-installed and set to zoom out.

otherwise, I pretty sure a hard re-set will fix the issue.  there is an app that allows you to backup your settings/apps.

Re: Camera stopped focusing -- help?
Sr. Member


On my Charge PHONE camera when I touch the screen to pre-focus it focuses, turns the focus Square from white to green, and gives a beep when it is focused.  It takes about 4-6 seconds until this happens.

BUT I also found that pre-focusing is not necessary because whenever I touch the camera icon to take a photo the camera FIRST focuses on the area in the white square, turns it green and gives the same beep denoting focus.  Then it takes the photo.  This means that if you have moved the white square away from where you pre-focused you have just lost that pre-focus.

Now if you want to point the camera on an object in the middle of the screen BUT you would like the focus to be on a persons face or an object on the right or left of whatever is in the middle just touch that area but it takes 4-5 seconds for it to pre-focus but don't move the camera's white square  away from the area you just pre-focused.

I find it easier to point the camera directly at a persons face and, forget the pre-focus, just take the picture because when you take the photo the camera does BOTH the focus and the picture taking.

I think with this "little" camera you might be happier if you set the FOCUS MODE to AUTO FOCUS and METERING to SPOT so the main focus is where the white square is located.


Re: Camera stopped focusing -- help?

So now I think the camera is just messing with my head.  It took one picture nicely focused, then went back to not focusing.  So I tried Camera ICS, and it works better.  Not as well as the basic Camera did a few months ago, when focusing was fast and good, but now it's slow and works some of the time.  Maybe a hard re-set would works, but that's just too much of a hassle.  At least now I know the problem is not that the hardware is broken.