DroidX not syncing with gmail
jolyntav
Newbie

Hello, hopefully someone can give me some advice, I have 6 gmail accounts (yes i know that is quite a lot) and had 5 of them set to auto sync so I would be notified when I received a new email. My husband tried to be helpful and adjusted some things so my batt would last longer, and now my gmail isn't even syncing, i have to go to each to and manually refresh to get email, and even then it takes a few refreshes to load any new email. He doesn't remember what he did, and I have gone through each account to set it to notify me, even taken each account off and reloaded it, still will not load. Any suggestions would be a help, i have two business accounts set on there and I need to know right away when i get an email. Thanks!

~Jolyn

0 Likes
Reply
33 Replies
CraigWar
Newbie

Okay, I started having this problem a few months ago, and found things that worked for short spurts, and finally something that seems to be working consistently.

The first thing I found was that most of the suggestions I found online worked, but only temporarily.  This included powering off/on, clearing the cache, uninstalling all the updates and disabling the automatic updates, reinstalling the updates, the list goes on.  But it was never working for more than a few hours, no matter what I did.

Finally, I went into the Settings/Account/gmail section, and turned off every sync type *except* for the mail itself.  No google+, no contacts, no calendar, nothing but email.  Success.  It now stays up and running.  The next step is to gradually re-enable the synchronization selections one by one (starting with what I need the most, calendar and contact sync), waiting a couple of days after each one until I find the one that's killing it all.  Then I'll be shouting to the world about which one it is, and telling everyone to turn it off until Google and/or Verizon fix it.

So, if I get back to this post, I'll update with the culprit, if not, follow my steps and you'll get there yourself.

Good luck! Smiley Happy

UPDATE: Two days now, still working. Email, calendar and contacts all enabled.  It's usually stopped by this time...  Still looking for the guilty sync...

UPDATE 2: Okay, so 3 days in, still working great, enabled Google+ sync, no issues for 24 hours.  THEN, 4 days in, I enabled the Sync Google Photos.  BAM!  Stopped syncing immediately.  I removed the Sync Google Photos, but the sync did not return, so I rebooted my phone to reset the sync service (since I couldn't tell for certain which service to restart, nor how to restart it once I killed it.)  When the phone came back up, so did the sync, and it's working now.  So, either the Google Photos causes it, or maybe any of the cloud drive sync options causes it.  Or, maybe it happens when 5 or more sync options are selected.  It's definitely linked to the Google sync, any way you look at it.  But email + calendar + contacts + Google+ works without issue for me now.

0 Likes
Reply
bluehand70
Newbie

I'm having the same problem. 

Droid X, using a single gmail account, and using the stock gmail app.

I've checked to make sure sync is on and also cleared the cache for the app.

0 Likes
Reply
smartphoneguru
Contributor - Level 1

How long have you had this problem? And have any of you recently activated the 2 step verification preference on Google?

http://www.droidxforums.com/forum/droid-x-help/43075-what-happened-help.html

0 Likes
Reply
bluehand70
Newbie

Hard to pick a firm date, but I started noticing my email not updating about 1 week ago, +/-.

I haven't yet activated the 2 step verification.

The mail will arrive on my phone, but it's always very delayed.  When I launch the app and hit the refresh button, then it'll all update.

It's never asked for my password, so I don't think it's having any issues in that area.

0 Likes
Reply
smartphoneguru
Contributor - Level 1

Have you tried Settings>Manage Apps>All>GMail(or what you use)> clear cache. ?

If that does not work you could select "clear data" (THIS WILL REMOVE YOUR EMAIL ACCOUNT AND SETTINGS on your device) and then you would have to set up your email account on the device again, so you would need to make sure you have a back up or your sync'd to your inbox online.

0 Likes
Reply
bluehand70
Newbie

Cache clearing didn't work, but "clear data" seems to have done the trick.

I was hesitant, but it all updates like it was never gone. (why I love google!)

Thanks for your help.

0 Likes
Reply
smartphoneguru
Contributor - Level 1

I know! I love Google. It backs everything but my ROM!

On Jan 26, 2012 10:13 AM, "bluehand70" <community@verizonwireless.com>

0 Likes
Reply
jolyntav
Newbie

Yeah i have tried the clear data feature, 3 times now, and it still will not alert me when I receive a new email, I would really like not to have to reformat the phone, or take it back to factory install, but I really need this to work.

0 Likes
Reply
smartphoneguru
Contributor - Level 1

Have you went to the settings menu and under the battery settings there

should be a option for mobile data or data sync. You may have to create a

custom battery profile or try performance option.

0 Likes
Reply
jolyntav
Newbie

nope! Trying it now . . . willing to try anything and eveything lol . . .and ok yeah i have that all set up correctly . . . also under default email account, it will only let me chose Yahoo, could that be a problem?

0 Likes
Reply
smartphoneguru
Contributor - Level 1

Yeah, there should be a couple of different email choices under accounts

there should be auto sync or add accounts and stuff. Background data and

auto sync should be on

0 Likes
Reply
smartphoneguru
Contributor - Level 1

Also it is possible you could have a sync on or off issue, here is a previous thread that was corrected.

https://community.verizonwireless.com/message/664593#664593

0 Likes
Reply
htcincredible2

I believe that Verizon has something wrong with the GMAIL.  I had my gmail working fine through mail and then yesterday afternoon it completely stopped when I try to delete and add my account again it gives an error message of 503 80345: The passowrd and username you entered did not authenticate with your email provider. Please try again.  I know that my user name and password are correct because when using the GMAIL APP all works fine so I think VERIZON has a bug that needs to be fixed.

0 Likes
Reply
jolyntav
Newbie

hmm well I have reloaded each of my accounts and that has all worked for me.mine just won't tell me when I have new email and now I have noticed it take a long time to send and refresing doest always get my email 😞

0 Likes
Reply
htcincredible2

I had to delete all of my mail accounts including an outlook account and

then set up gmail account again and now it is working. I still think it is

a bug as it was working fine yesterday morning. Thank you!

0 Likes
Reply
jolyntav
Newbie

yes I also took all my acconts out and reloaded them and it worked the first time but now it is doing it again and tje reloading isn't workng 😞

0 Likes
Reply
B33
Legend

Jolyn:  Give this a Try on your computer go to your Gmail account an Log in: Once in there have you got any folders set up if not you might try setting up seperate folders for different things. Business Acc's, Personal things, Pictures things like that. An once a day or every other day take what you get in your main mail Box an send it to the file you made up to clear up you main Mail box this is what i Do on mine. An it help my mail flow a-little smoother. An the stuff i figure i don't need i file it No.13 give this a try an hope it Helps. B33 Smiley Happy  

0 Likes
Reply
jolyntav
Newbie

well I keep my inbox clean less then 20 usually so ibdont thnk that will really help but thanks

0 Likes
Reply
bearone21
Legend

i've got 20+ in my gmail inbox & it syncs fine.

mort78
Enthusiast - Level 2

Try opening a Gmail account. Tap on menu and on More. Tap on Settings and on your address for this account. Scroll down to Email notification. Is it checked off? If not, check it off. If that works, then do the same thing with the other Gmail accounts. Hope this helps, and works.

0 Likes
Reply