Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
Speakerphone comes on automatically for every call
acejavelin
Newbie

Several days ago, my DROID Incredible 2 just started automatically going into Speakerphone mode for every incoming and outgoing call and I can't get it to stop... I have had this issue a few times in the past but a soft reset  always fixed it, but for some reason that solution isn't working this time.

I have tried these things:

1) Reset phone (via power button option)
2) Battery pull reset
3) Verified Dock Mode is not set to Auto Start ( I have no dock)
4) Clean USB plug with canned air and verified no visible damage, short, or loose connector socket
5) Re-calibrated G-Sensor

6) Turned off "Flip for speaker" feature


Not really sure where to go from here, thinking the next step might be a hard reset to factory defaults but really not looking forward to that option, any ideas before I take that step?

0 Likes
Re: Speakerphone comes on automatically for every call
acejavelin
Newbie

Tried booting phone into "Safe Mode", problem is still there... Any ideas, or is a hard Factory Reset my only option right now?

0 Likes
Re: Speakerphone comes on automatically for every call
acejavelin
Newbie

Looks like it won't be an issue anymore...

Well, I did the factory reset and no change, except now the Dock mode started every time I reset.

Took it in to my local Verizon store and they factory defaulted it twice, couldn't do anything with it, and tried to get me a warranty replacement, but Verizon didn't have any so they called tech support and were told there are no DInc2's anywhere, but instead they will replace it with a Samsung Stratosphere and that was only option unless I wanted to call HTC myself and see what they would do... not really sure how to feel about that, I only know one person that had one and they didn't really have anything good or bad to say about it.

I will probably call HTC tomorrow, but it looks like I am going to be stuck with the Samsung Stratosphere instead.

0 Likes
Re: Speakerphone comes on automatically for every call
RedNBlack
Newbie

I came in to suggest the "Flip" feature you've already mentioned.  That seems like a silly useless feature to me anyway.  Too bad, I inherited my Inc2 and love it so far.  (Prev Iphone user)  Compared to an Iphone, it's a bit more cumbersome, but nonetheless a good smartphone.  Perhaps you'll love the Stratosphere! 

0 Likes
Re: Speakerphone comes on automatically for every call
mnkaren
Newbie

Try turning on the flip for speaker feature on and then off again (located under sound settings). That worked for me.

0 Likes
Re: Speakerphone comes on automatically for every call
MICMCN20
Enthusiast

Fixed mine. Settings-} Advanced calling-} Advanced calling turn on//off HD wifi video calling.

I remembered that I had enabled that option a week ago. I had cleared the cache and all but problem persisted. I turned the option off and it reverted to working properly.

I figure it was one of those developmental options that hasn't gotten all the bugs out yet.

Hope this helps others.