Another texting problem

I just upgraded today to a 4GLTE Thunderbolt, I love the speed.


However I cannot send text messages.  I can receive them.  When I try to send I get error 97, class 2.


Text Messages worked when I first got the phone, but quit working since then.  I tried rebooting and that did not fix it.  I removed several apps that I saw online as suggested culprits, that did not resolve it.  I removed my facebook account as suggested and that has not resolved it. 


I tried *228 only to be told that my phone was activated by SIM card and therefore the *228 didn't matter.


Any other suggestions?

Re: Another texting problem
Community Leader
Community Leader
Try turning off the phone, removing the battery and SIM card for thirty seconds. Then put it back together and turn it on. Send another test message.

If that doesn't work, call customer service from a different phone and verify that there isn't a provisioning issue with your line.

I'm most definitely NOT a VZW employee. If a post answered your question, please mark it as the answer.

Re: Another texting problem

Here is a post that reported a solution,,,,


sfetaz's Avatar
PPCGeeks Regular
Pocket PC: CDMA Touch Pro 2
Carrier: Verizon
Join Date: Jul 2007
Posts: 112
Reputation: 25
sfetaz is just getting started
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Re: "Verizon is unable to authenticate your phone" message after upgrade

Called Verizon, was issued new Authentication number, phone works. Thanks guys!