LG G2 Constantly "Searching" for wi-fi even though it is already connection to wi-fi
mwkv
Enthusiast - Level 1

My LG G2 connects just fine to the wi-fi, however it is constantly "Searching" and that is using up the battery while on wi-fi. Any way to stop the constant "Searching" for a wi-fi connection while on wi-fi ?

18 Replies
vzw_customer_support
Customer Service Rep

@mwkv,

Connecting to WiFi is a great way to help manage your data usage. I use it all the time when at work and home. Constantly searching for the WiFi connection an definite use up your batter a lot sooner so I understand your concern.

Usually once connected to WiFi the device will stop searching for WiFI unless you're dropping the connection. When you see it searching for WiFi , have you checked to make sure you have not dropped the connection? Some time when it drops the WiFi connection you will not notice it because it will start using our network right away. Does this happen when connected to any WiFi or have you notice it happening only with one specific WiFi?

Try deleting the WiFi connection http://vz.to/1jKIiYd and adding it back.

Keep me posted if the issue continues.

JohnB_VZW

Follow us on Twitter @VZWSupport

0 Likes
Reply
phil2s
Enthusiast - Level 2

i got the same issue. even in excellent connection, right next to a router, G2 keep searching wifi networks.

nothing wrong with normal use.

it could save some battery,if solved.

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Hmm. That's certainly odd, phil2. I want to ensure you have a positive experience with your device. Have you ever tested the device in Safe Mode? http://vz.to/JuZQfu

YosefT_VZW
Follow us on Twitter @VZWSupport

0 Likes
Reply

GREAT QUESTION

I, too, have the same issue. The G2 says it is looking for a connection although I am already connected.  It is a nuisance and confusing message when nothing is actually wrong with the phone or am I missing something?  Thank CW

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Hello Flibbergibbet
I would love to look into this with you.Let's solve that battery drainer. Have you tried deleting the wifi connection and retesting? Does this happen with different wifi connections? For example a public free wifi? Does it search in Safe mode?

I look forward to getting this resolved.
JoeL_VZW
Follow us on Twitter @VZWSupport

0 Likes
Reply
phil2s
Enthusiast - Level 2

I did factory reset twice to fix other issue ( exchange email push function issue and having only  "headers only" option along with this issue) 

Wi-Fi searching keep going on.

Again STILL battery power is good enough for 1 and half day.

Thanks.

0 Likes
Reply
vzw_customer_support
Customer Service Rep

phil2s, Thanks for those details. Can I ask you, after you did the factory reset, did you reinstall your apps right away, or did you wait and test the WiFi first? If you installed apps right away, Yosef's suggestion to try safe mode may still be beneficial to you. It checks if any app is affecting this issue. Please let us know, so we can continue to assist!

Thank you,
MichelleH_VZW
Follow us on Twitter @VZWSupport

0 Likes
Reply
landa22
Newbie

I have the LG G2 and I been having issues with the wifi...It will connect and disconnect thru out the day,...I did the Factory reset but it is still doing the same...

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Hello landa22,

Thanks for reaching out to us. I know how important it is to stay connected to a wi-fi network. Are you having issues staying connecting to just one wi-fi network? Or are you having the same issue no matter whos wi-fi you are connected to. Let's try deleting the wi-fi connection from the phone and reconnect. http://vz.to/1fCBiKH When you do this step it is going to ask for the wi-fi password again. Just a heads up. Keep us posted.

KevinR_VZW

Please follow us on Twitter @VZWSupport

0 Likes
Reply
landa22
Newbie

I have tried the following instructions, But it is still doing the same thing...hard to listen to a internet radio on my phone.

0 Likes
Reply
vzw_customer_support
Customer Service Rep

Thanks for the additional details landa22! It is common for devices to disconnect from WIFI if connection is not stable. Have you attempted to connect to an alternate WIFI Network? Have you reset your WIFI router? Please keep us posted, thanks!

Matthew_VZW
Follow us on Twitter @VZWSUPPORT

0 Likes
Reply
JT_
Newbie

I was having this same issue. I read a lot of posts and forums online about this same problem with the G2.

My problem ended up being router related. I have the router set WPA Mode : Auto

And here is what fixed is I had the Cipher Type set as TKIP and AES. I had to change it ti TKIP only. My phone has been connected for days now and have not had any drops. I had called my ISP thinking it was them and reset the router thinking it was that. It ended up being this small setting on the router. I hope this helps someone else.

I spent days wanting to pull my hair out after getting this phone.

PS since this is resolved I love this phone !!! Amazing.

0 Likes
Reply
GanjaRaised
Newbie

Im having the same problem with my phone constantly searching and disconnecting and reconnecting to wifi roughly every 30 seconds. Ive followed all the steps of running it in safe mode and removing and re adding the various wifi networks that Ive been trying to use, and changing the settings on my router. It doesnt matter if its a public or private network. Any help in resolving this issue will be greatly appreciated, Im ready to return this phone for a different brand.

0 Likes
Reply
stef7
Master - Level 2

Settings | WiFi

now press the menu button

now select Advanced WiFi

Try unchecking Wi-Fi signal weak.

0 Likes
Reply
GanjaRaised
Newbie

Thank You stef7, didnt realize there was an advance setting for wifi, the wifi signal weak box was unchecked already, I did uncheck the Battery saving for wifi box and have not had a problem since.

0 Likes
Reply
stef7
Master - Level 2

Forgot to mention that other setting. Yea, I came upon those "hidden" WiFi settings myself by accident. Probably lots of people don't know about them. I'm not impressed they are located where they are. A bit too much customization here and soooooo many people having problems with the update.

Hope that was root cause for you!

0 Likes
Reply
G2WasGreat
Newbie

I am having the same issue since upgrading to Lollipop.  Regardless of where I connect to WiFi, the phone continues "searching for WiFi".  I have even unchecked  "Allow Wi-Fi scanning" in the advanced settings.And the phone continues to scan for "WiFi".  ALSO, I have to keep data turned off.  Otherwise the battery will only last a couple of hours.  Very frustrating!!

0 Likes
Reply
stef7
Master - Level 2

With an LG G2?

Yeah turn off Allow WiFi scanning, and also Avoid bad WiFi connections.

If this is a G2, I even hate to propose it, but this is the sort of odd-ball behavior you might get post-uprate if you didn't perform a FDR. Which of course, you'd want to back up your personal content before doing something like that.

What you might want to try one time... Select both of those settings under Advanced WiFi. Power cycle your device. Now, uncheck both, and see if the behavior is different.

0 Likes
Reply