Caller ID Blocking - Outbound - How to??
NurseWalter
Enthusiast - Level 2

I'd like to know how to block my Caller ID on an outbound call. The guide here says to precede the call with *67 when dialing. When I tried that, I get a recording saying "all switches are busy". So I tried pressing "send" right after the *67, before dialing the number, and got a recording saying the number could not be connected as dialed.

So what is the correct method of blocking an outbound Caller ID?

Labels (1)
Tags (1)
0 Likes
Re: Caller ID Blocking - Outbound - How to??
NurseWalter
Enthusiast - Level 2

Sorry, it says "all CIRCUITS are busy, not all "switches".

0 Likes
Re: Caller ID Blocking - Outbound - How to??
drcoracle
Newbie

I need the answer to this question as well. I should be able to BLOCK my caller ID. I had another phone with a simple setting to do so.. Why not one on my 6S?

And *67 does not work. I am on Verizon

0 Likes
Re: Caller ID Blocking - Outbound - How to??
NurseWalter
Enthusiast - Level 2

It is plastered all over the internet, and in all of Verizon's help system, that *67 is the way to do it. I have to think they must have recently disabled this ability, without making any changes to their support documents.

0 Likes
Re: Caller ID Blocking - Outbound - How to??
naansalad
Specialist - Level 3

can you turn phone off and on then try *67and ten digit number to call and see if that works

Re: Caller ID Blocking - Outbound - How to??
NurseWalter
Enthusiast - Level 2

Well, to my surprise, that worked. Smiley Happy I say this because I reboot my phone weekly, so I did not think it would help, but it did. Thank you!