Skip to main content
Accessibility Resource Center Skip to main content
Have a phone you love? Get up to $500 when you bring your phone.
end of navigation menu
cancel
Showing results for 
Search instead for 
Did you mean: 
need help setting up UML290 4g modem on SuSE Linux 11.3
idee
Member

greetings,

   I have been digging through this forum and found other users that have had success in setting up their UML290 with both Mac and Linux. Ref:  http://community.vzw.com/t5/4G-Discussion/4G-LTE-Data-stick-Mac-Linux-Windows-other-authentication/t...   I took the plunge and signed for the new device.  It has been activated and initialized using windows XP Pro.  I have installed the modem device using YaST2 (configuation tool), set as /dev/ttyASM0 , set to #777 mynumber@vzw4g.com, etc.  I am using Qinternet to make the connections.  Below is the log, as it won't connect.

 

Qinternet.logSuSE Meta pppd (smpppd-ifcfg), Version 1.60.46 on linux-ib6d.Status is: disconnectedtrying to connect to smpppdconnect to smpppdStatus is: disconnectedStatus is: connectingpppd[0]: Plugin passwordfd.so loaded.pppd[0]: speed 480000000 not supportedpppd[0]: --> WvDial: Internet dialer version 1.60pppd[0]: --> Initializing modem.pppd[0]: --> Sending: ATZpppd[0]: ATZpppd[0]: OKpppd[0]: --> Sending: AT Q0 V1 E1 S0=0 &C1 &D2 +FCLASS=0pppd[0]: OKpppd[0]: --> Sending: ATM0pppd[0]: ATM0pppd[0]: OKpppd[0]: --> Sending: ATX3pppd[0]: ATX3pppd[0]: OKpppd[0]: --> Modem initialized.pppd[0]: --> Sending: ATDT#777pppd[0]: --> Waiting for carrier.pppd[0]: ATDT#777pppd[0]: NO CARRIERpppd[0]: --> No Carrier!  Trying again.pppd[0]: --> Sending: ATDT#777pppd[0]: --> Waiting for carrier.

  

  Basically, what am I doing wrong, and how do I correct it?  I have been using the Pantech UM175 over the past years with success. There is also reference in the other post that this can or should be set up as an ethernet device.  How can that be done?

 

4G LTE GSM General Device Settings-Phone Number: PhoneNumberAccount name: PhoneNumber@vzw4g.comPassword: vzwAdvanced Settings-Carrier: GenericModel: GPRS (GSM/3G)APN: vzwinternetCID: 1

 

 

thanks in advance for any help,

idee

Labels (1)
Tags (1)
0 Likes
1 Solution

Correct Answers
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
idee
Member

OK, I have tested about all I care to at this point.  I have a g3 connection on Linux using the Pantech UML290 from Verizon.

 

Open SuSE 11.3

Kernel Linux 2.6.34.7-0.7 desktop

Gnome 2.30.0  (using LXDE)

QInternet for connections

 

Modem installed as /dev/ttyACM0

Tone Dial, Speaker Off, Detect Tone Dial Off

Details (default settings)

  Buad Rate - 480000000

  Init 1 - ATZ

  Init 2 - AT Q0 V1 E1 S0=0 & C1 &D2 +FCLASS=0

Enable Device Control Via Qinternet

 

Provider information:

   Name: vzw4g #777

   Phone Number: #777

   User Name: yourphonenumber@vzw4g.com

   Password: vzw

Manual (defaults for all of the rest of the settings)

 

 #777 provided the quickest (almost instant) connection to the carrier.  *99# & *99***3# also worked, but after a 60 second or longer wait.

 

The primary reason for the successful 3g connection seems to be the use of the Pantech Tool posted by Toughbook (linked here) at the Verizon forum.  This process is all done under windows.  Be advised, if you have the tool "read" your device, you must write, even if you made no changes.  If you don't it won't work under the VZAccess Manager.

 

  The default settings (AT+CGDCONT?) on your UML290 should be:

+CGDCONT: 1,"IPV6","vzwims","0:0:0:0:0:0:0:0",0,0
+CGDCONT: 3,"IPV4V6","vzwinternet","0.0.0.0",0,0
+CGDCONT: 4,"IPV4V6","vzwapp","0.0.0.0",0,0

 

  It seems that the modem might connect directly under SuSE Linux without any complications using the modem configurations and provider information above.  I am in a 3g area right now (4g is support to be here this summer) and when I try to connect with the unit straight out of the box, everything connected, but it found no carrier.  I'll know more once 4g is in our area.  There were a couple of other posts mentioning a direct hook up in Fedora.  I could not find any direct posts confirming that, but I am guessing this is the case.

 

  Willzzz suggested various options and tests (here post #12) on the Ubuntu forum.  I set up and tried all.  The test was to see if I could force the APN to see the 3g system under the 4g settings (out of the box, without the Pantech Tool alteration).  I was not successful with any.  I tried using all three of the AT+CGDCONT versions above in the Init3 setting.  Phone numbers of *99#, *99***3#, and #777. Even though both options (within the init string & in the dial-up number) are supposed to change the APN, neither worked for me.

 

Many of these items have been discussed before in various posts in this forum.  I don't claim credit for anything, but trying various options.  Thanks to Neander, Willzzz88, Irieblue and Toughbook, among the others that added to those posts.  The reason for the detail in this post is simply to document what I tried, what worked and what didn't hoping it might help others connect.  Thank you all for your expertise on this forum.

 

idee

 

View solution in original post

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
Neander
Novice

You didn't state in your question whether you're in 3 or 4 G territory.  If you're in 4G  ignore this.

 

It's a little over my head Idee, I haven't messed with Suse in years.   I don't know if you've checked out this 6-page discussion:

 

http://community.vzw.com/t5/4G-Discussion/Urgent-need-help-with-Ubuntu-10-10-4G-LTE-and-Pantech-UML-...

 

regarding Ubuntu 10.10.   I've got 4G running in Ubuntu and I've heard Fedora is freindly.        The up-shot of the above discussion is that you have to be in a good 4G area to get it to work under any Linux disto.   The Pantech290 will only kick down to 3G under windows/mac VZWAccess Manager,    which Verizon hasn't seen fit to produce a Linux version yet.

 

Toughbook may have come accross a 3G solution here:

 

http://community.vzw.com/t5/4G-Discussion/Good-Solution-For-The-3G-to-4G-Handoff/td-p/390032

 

I tried installing VZWAccess Manager under WINE.   It installs and looks good.   But as promising as the WINE project is, they still can't install Windows hardware drivers.    I can't get the Linux-run Access Manager to recognize the modem   -although Ubuntu's PnP has no problem with it..     Good luck

 

 

 

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
idee
Member

I just finished reading your adventures with Ubuntu and working through this.  wow, life on the bleeding edge.

 

OK, I am in Kansas City, it is currently 3g, with 4g supposed to be here mid year. 

 

You mentioned wine, I had the same results with VirtualBox.  I have seen mention of the Fedora success, but no details.  Fedora is not debian based is it?  So perhaps I can glean some information there if needed.  Do you know any information or posts?  I checked the Fedora forums, but found nothing.

 

Before I try the Pantech utility (downloaded it today), all I have to do is reset it and it should be back to 4g, correct?  But from what I have read, and what you state, it is either one or the other, it won't move automatically at this point for any OS but 'doze.  Is this right?  I just don't want to take the risk of screwing the device up and not being able return it if needed.

 

Sorry, if this is basic, but what is the APN?  I don't have that setting in any of my configs.  But if I'm understanding the other post (6 pager) #34 & 35:

 

 

The Pantech UML290 is set to eHRPD by default for CDMA. You need to use the UML290 Prefer Mode Tool (posted above) to set the modem to use EVDO Rev A. After doing this, it will connect in Linux & Mac on the 3G network. You use the same methods to get online, e.g., *99***3#... not #777.

 ... the APN may be set by this string.  The defaults on the device are:

+CGDCONT: 1,"IPV6","vzwims","0:0:0:0:0:0:0:0",0,0+CGDCONT: 3,"IPV4V6","vzwinternet","0.0.0.0",0,0+CGDCONT: 4,"IPV4V6","vzwapp","0.0.0.0",0,0

 So if that's the case, I don't need to set it.

 

Unless I hear from someone not to, I think this is what I will try.

 

 

 

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
willzzz88
Member

Again CHANGE THE CID TO #3 and MAKE SURE THE DEFAULT VZW SIM CARD APN INFO for 4G IS CORRECT! My initial data is WRONG and screws up the SIM card. I should be deleting that post for those people who don't have the engineering knowledge.

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
idee
Member
Again CHANGE THE CID TO #3 and MAKE SURE THE DEFAULT VZW SIM CARD APN INFO for 4G IS CORRECT!

 How do I change the CID to #3?  Is that done by using  *99***3#

 

  As for the Default APN info, I don't think I changed anything. 

  Is this what you mean, from at+cgdcont?

+CGDCONT: 1,"IPV6","vzwims","0:0:0:0:0:0:0:0",0,0+CGDCONT: 3,"IPV4V6","vzwinternet","0.0.0.0",0,0+CGDCONT: 4,"IPV4V6","vzwapp","0.0.0.0",0,0

 

 All I have done is use the (toughbook) Pantech Tool mentioned above.  So it that correct?

 

  A note about the Pantech Tool.  If you "read" and then want to exit, doing nothing, it screws up the card.  At least the the VZaccess Manager can't find any signal at all.  So even if you don't want to make a change, if you read, you MUST write it back to itself or the card is dead.

 

  A note about VZAccessManager in VirtualBox under Linux, I mentioned above that it installed, but couldn't find the device.  The previous version did find my UM175 and access the internet within VB on XP Pro.  Hopefully this one will too, once all is set correctly.

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
Neander
Novice

Idee; You're the pioneer on this one.   No one I know has been able (so far) to connect at 3G on any Linux disto.

 

The features of VZAccess Manager & the Pantech290 are joined at the hip.   Access Manager is a lot more forgiving regarding signal strength.  If you're in Windows  and you slip from a 4G to a 3G area it seamlessly switches.  If the signal drops, you're not automaticly disconnected.    It's a wonderful thing when it works as planned.

 

But in Linux, with nothing like an Access Manager running,  when the signal drops (and it does a lot) you're dropped.  No questions asked.

 

The modem is set at a 4G default.     So in Linux;  No 4G signal =  No Connect.  Period.  Forget automatic switching

 

If all you've got is 3G  and  all you've got is a Linux distro,   for now you're S.O.L.....

 

Unless you can figure out a way to re-set the default on the Pantech  to 3G (In Windows you can change the default in Access Manager but that's a useless software fix to you under Linux.)      You're on the leading edge on this one.  Make it work and you're a hero for a lot of Linux users

------------------------------------------------------------------------------------------------------------------------------------------------

My settings:  Here's what worked for me in Ubuntu(4G)  default phone : *99#,  APN: vzwinternet  Password: vzw Your connect type should be : Any  

 

Much of the information that Verizon needs is wired into your SIM chip; User Name etc..   And Willz99 has covered it in detail elsewhere.   You can manipulate those settings by following what we learned from IreBlue here:

 

http://community.vzw.com/t5/4G-Discussion/I-am-getting-an-error-Message-when-trying-to-connect-to-4g...

 

Be sure to read to the end because I offered some wrong info in places.

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
idee
Member

Thanks for the help.  I just got connection with 3g, so that is good!  I have a couple other tests I want to run, then I'll get back here with what I find.

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
idee
Member

OK, I have tested about all I care to at this point.  I have a g3 connection on Linux using the Pantech UML290 from Verizon.

 

Open SuSE 11.3

Kernel Linux 2.6.34.7-0.7 desktop

Gnome 2.30.0  (using LXDE)

QInternet for connections

 

Modem installed as /dev/ttyACM0

Tone Dial, Speaker Off, Detect Tone Dial Off

Details (default settings)

  Buad Rate - 480000000

  Init 1 - ATZ

  Init 2 - AT Q0 V1 E1 S0=0 & C1 &D2 +FCLASS=0

Enable Device Control Via Qinternet

 

Provider information:

   Name: vzw4g #777

   Phone Number: #777

   User Name: yourphonenumber@vzw4g.com

   Password: vzw

Manual (defaults for all of the rest of the settings)

 

 #777 provided the quickest (almost instant) connection to the carrier.  *99# & *99***3# also worked, but after a 60 second or longer wait.

 

The primary reason for the successful 3g connection seems to be the use of the Pantech Tool posted by Toughbook (linked here) at the Verizon forum.  This process is all done under windows.  Be advised, if you have the tool "read" your device, you must write, even if you made no changes.  If you don't it won't work under the VZAccess Manager.

 

  The default settings (AT+CGDCONT?) on your UML290 should be:

+CGDCONT: 1,"IPV6","vzwims","0:0:0:0:0:0:0:0",0,0
+CGDCONT: 3,"IPV4V6","vzwinternet","0.0.0.0",0,0
+CGDCONT: 4,"IPV4V6","vzwapp","0.0.0.0",0,0

 

  It seems that the modem might connect directly under SuSE Linux without any complications using the modem configurations and provider information above.  I am in a 3g area right now (4g is support to be here this summer) and when I try to connect with the unit straight out of the box, everything connected, but it found no carrier.  I'll know more once 4g is in our area.  There were a couple of other posts mentioning a direct hook up in Fedora.  I could not find any direct posts confirming that, but I am guessing this is the case.

 

  Willzzz suggested various options and tests (here post #12) on the Ubuntu forum.  I set up and tried all.  The test was to see if I could force the APN to see the 3g system under the 4g settings (out of the box, without the Pantech Tool alteration).  I was not successful with any.  I tried using all three of the AT+CGDCONT versions above in the Init3 setting.  Phone numbers of *99#, *99***3#, and #777. Even though both options (within the init string & in the dial-up number) are supposed to change the APN, neither worked for me.

 

Many of these items have been discussed before in various posts in this forum.  I don't claim credit for anything, but trying various options.  Thanks to Neander, Willzzz88, Irieblue and Toughbook, among the others that added to those posts.  The reason for the detail in this post is simply to document what I tried, what worked and what didn't hoping it might help others connect.  Thank you all for your expertise on this forum.

 

idee

 

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
Neander
Novice

Congradulations!   You're the first I ever heard that has the New Verizon 4G / 3G running under Linux! In 3G Territory.

 

When ever I googled for the solutions,  Google directed me back to our own forums here.   I got the impression that this is/was the leading edge of this problem.   Hopefully people are going to connect from all over the internet to see how you did it.

 

I'm motivated now myself, as I just moved into a 3g only area. (Man is it slow!)   Linux distro's need a lot of downloads to make the OS functional.   Looks like I'm going to spend a lot of time in Krystal Hamburger to get a decent speed when I need it.

0 Likes
Re: need help setting up UML290 4g modem on SuSE Linux 11.3
Neander
Novice

Never mind; I just checked the links that answered my questions below.

 

Idee;   Just a few "surface" questions.

 

I'm currently on the edge of a 4G area and will be jumping back & forth under a couple of OS's.

Did you configure your UML290 to 3G only?  

Does/will it switch automaticly? 

Is it a lot of work to switch it manually? What would you do?

 

I may just wait for a Linux VZA .   ..maybe if I hold my breath...

0 Likes