Can't get MoCa adapters to work
soccastar0011
Enthusiast - Level 3

I just got Fios Gigabit ethernet.  The Cat5 from the ONT comes into my house on the second floor where my office is and connects to the router there as well as a coax line from the wall.  I'm using my own router so I followed the instructions here:  https://forums.verizon.com/t5/Fios-Internet/Using-your-own-router-with-Verizon-FiOS/td-p/851632 and everything works great.  I do have both TV and internet service and all my data features on the set top box work (on demand, guide, messages) and my own router is working fine.

However I want to have a wired connection to my entertainment center on the first floor.  My house is wired for coax and everything I've looked up gave me the understanding that with just a MoCa adapter I could connect my entertainment center to the gigabit network.

Well I haven't been able to get it to work.  I've tried two different methods.  First I used a MoCa 2.5 adapter that had both a coax and ethernet out so I could connect my set  top box as well as my switch.  Doing this my set top box stopped being able to access data features like on demand and I had no network connection to my other devices like my XBox.  I removed the adapter and tested the direct line to the set top box again and the data features returned.

So I figured maybe that MoCa adapter was the issue so I tried another but this one only had ethernet out.  So I used a splitter, sent one end directly to the set top box (it worked fine) and the other to the MoCa adapter.  Unfortunately still no network connection on my XBox.

Finally I tested removing the set top box from the equation entirely in case the splitter was the problem.  Coax into MoCa into XBox.  Still no network connection.

What am I missing or doing wrong?

0 Likes
Reply
1 Solution
gs0b
Community Leader
Community Leader

The "TV Out" connector on the goCoax adapter filters MoCA signals, as it's for a non-MoCA TV.  You can't use this output for a Verizon set-top-box.  Use a splitter to feed both the goCoax's input and the set-top-box.  Leave the goCoax's "TV Out" connector unused.

Make sure you understand the full coax network between the ONT and the various devices.  While MoCA can traverse lots of splitters, it doesn't do well with amplifiers or very large numbers of splitters.  And remember that an 8-way splitter is really seven 2-way splitters inside a single case.  If you've got more splitters than needed, remove some.  If there are any amplifiers installed, remove them - they are not needed for fios.

And follow Cang_household's suggests for a step-by-step debugging process.

View solution in original post

12 Replies
gs0b
Community Leader
Community Leader

The 2017 FAQ about using your own router is dated.  For example, is not correct for the latest FIOS ONE set-top-box system.  I'm guessing you don't have FIOS ONE, as your set-top-boxes are working without a Verizon router in the mix.  Also, the instructions to do DHCP releases when switching routers no longer applies.

Rather than have us try and guess how you've setup your router and MoCA adapter(s), please provide a diagram showing how everything is connected.   Something has to create the MoCA LAN, and it's not clear from your description how your system is setup.  I suspect the answer will be much clearer if you can provide this information.

soccastar0011
Enthusiast - Level 3

image

So this is how my current setup looks.  I'm trying to use a MoCa adapter where the coax comes from the ONT to the Set Top Box (which is older so I doubt it's the One) in order to wire ethernet to devices in my living room which is far away from the second floor office where the OnHub and G3100 are.

0 Likes
Reply
gs0b
Community Leader
Community Leader

You've left out the coax splitter(s); the ONT only has one coax output so I know there has got to be at least one somewhere.

Assuming there is a splitter at the ONT feeding the G3100 and the set-top-box, this should work.

As a trouble shooting step, remove the OnHub router and connect the G3100 directly to the ONT's Ethernet.  Then report results.

Are you using a splitter to feed the set-top-box and the MoCA adapter?  If not, that's a problem.  The set-top-box needs MoCA, too.  The coax out of the adapter filters MoCA.  Use a splitter.

Another possibility is the various coax points may not bel connected together.  If you can trace down where splitters are and should be, you'll likely find the issue.

soccastar0011
Enthusiast - Level 3

You're correct, there is a splitter at the ONT feeding the G3100 and the set top box.

I believe during troubleshooting I tried the MoCa adapters using just the G3100 and not the OnHub but I will try again in the morning to double check.

I tried two different MoCa adapters.  One had an ethernet and coax output.  When I used this the set top box lost data and the ethernet didn't receive it either.  The other had just an ethernet output so I used a splitter with that one.  One end of the splitter I connected directly to the set top box and it maintained data.  The other I connected to the MoCa adapter and the ethernet output did not have data.

It seems no matter what I try the connection dies in the MoCa adapter since I know I have data via direct connection or via a splitter that bypasses the MoCa adapter.

0 Likes
Reply
Cang_Household
Community Leader
Community Leader

Can you disconnect all MoCA devices from the network except the G3100? Then, connect one MoCA device at a time and monitor the changes in LAN Coax Stats of the G3100. LAN Coax Stats can be accessed by going to Network > Network Connections > Network (Home/Office) > Coax > Settings > LAN Coax Stats.

If a MoCA device is plugged in but does not get displayed in LAN Coax Stats, you can know that device needs troubleshooting.

soccastar0011
Enthusiast - Level 3

I'll try that, thanks. 

0 Likes
Reply
soccastar0011
Enthusiast - Level 3
0 Likes
Reply
gs0b
Community Leader
Community Leader

The "TV Out" connector on the goCoax adapter filters MoCA signals, as it's for a non-MoCA TV.  You can't use this output for a Verizon set-top-box.  Use a splitter to feed both the goCoax's input and the set-top-box.  Leave the goCoax's "TV Out" connector unused.

Make sure you understand the full coax network between the ONT and the various devices.  While MoCA can traverse lots of splitters, it doesn't do well with amplifiers or very large numbers of splitters.  And remember that an 8-way splitter is really seven 2-way splitters inside a single case.  If you've got more splitters than needed, remove some.  If there are any amplifiers installed, remove them - they are not needed for fios.

And follow Cang_household's suggests for a step-by-step debugging process.

soccastar0011
Enthusiast - Level 3

I got it working!  Thank you everyone for all the help.

It turns out that the issue was how a switch was interacting with the network.  On the main floor where the set top box was I have a dumb switch for getting a connection to several different devices.  When I plugged the MoCa into the switch none of those devices was getting data but when I plugged directly into a device it would.

THEN plugging the device back into the switch I would get data.  My guess is that the devices each needed to connect directly to the MoCa without the switch for some kind of DHCP or other network configuration then they were good to go through the switch.

Thanks again for putting up with me the past few days and thanks again for all the direction, definitely helped.

gs0b
Community Leader
Community Leader

Appreciate the update and glad you got it working.

Now you may understand why I and others asked for pictures and diagrams; there was no mention of a switch until your most recent post.  We often see threads like this where the OP leaves out a detail as they don't think it's important, but it turns out to be important.

I'm assuming you mean an Ethernet switch.  If so, having one attached to the Ethernet port on a MoCA adapter and then plugging devices into it should work fine.  The switch should happily  pass DHCP packets between the router and devices.  If it's not, there's a problem with the switch or it's not as "dumb" as you think it is.  If you want to investigate further, post detailed diagrams showing the Ethernet connection from the MoCA adapter to the switch and then to the devices.  Include the switch's manufacture and model number.

Cang_Household
Community Leader
Community Leader

May you picture all connection points? I think you might have connected the coax wire to the wrong port.

soccastar0011
Enthusiast - Level 3

I can take pictures but I'm not sure how I can connect the coax to a wrong port when every piece in this setup only has one coax port.  I have coax coming from the wall into the back of the quantum gateway.  I also have coax coming out of the wall going into the set top box.  The set top box currently works fine this way with the data features.

If I instead plug the coax going into the set top box into a MoCa adapter I don't get data out of it either through ethernet or coax.

0 Likes
Reply