My Jetpack MHS815L Admin password and reset question are saying wrong



My Jetpack MHS815L Admin password and reset question are saying wrong password and answer. I can't get into my settings at all to see how it's configured . It says it updated the new firmware on my PC. I tried the default code that I now can't find and that never works and it can't factory reset without the admin account. I feel I'm stuck in a loop. What should I do? I tried everything online. 


Thank you


Labels (1)
2 Replies
Customer Service Rep

Good morning, Hypnosguy0806. We want to continue to ensure this is reviewed to the best of our ability. How long has this been happening for? AnthonyM_VZW

Champion - Level 1

See page 2 of the User Guide:

press the Power button quickly, when the display is on, to cycle through the menu:
• 1st press shows data usage information.
• 2nd press shows Wi-Fi Name.
• 3rd press shows Password.
• 4th press shows Settings & Info http://my.jetpack
• 5th press returns to the Home screen.

Accessing Advanced Settings
To access Advanced Settings and manage the Jetpack, sign in to the Jetpack Admin website by following the steps below.
1. Connect your Wi-Fi–capable device to the Jetpack using the steps outlined in the Connecting Devices to the Internet section.
2. Open a web browser on your connected device and enter http://My.JetPack or
3. Sign in with the admin password. The admin password is the same as your admin password is the same as your Jetpack’s Wi-Fi password.NOTE: You can change the admin password and Wi-Fi password on the Jetpack Admin website.

Resetting Your Jetpack
To power reset your jetpack, follow the steps below.
1. Open the SIM card slot cover.
2. Use one end of a small, unfolded paperclip to gently press the Power reset
button until the Jetpack turns off and on again.

NOTE: Only use this button when your Jetpack requires a power reset. The Power reset button is provided because your Jetpack battery is not removable.
To reset your Jetpack software to the factory default settings, follow the steps in Accessing Advanced Settings and then go to Jetpack Settings > Jetpack > Factory > Reset


Perhaps you have a WiFi profile saved on whatever device you are attempting to connect to the Admin page from.  If the profile is incorrect the Jetpack might not let you connect.  You could connect with a different device temporarily or attempt to find and remove the old WiFi profile on the original device.  One way or another if you are correctly typing in the password from the Jetpack and match the password security mode (WEP, WPA, WPA2, etc.) then you should be able to connect.