Spam blocker
Enthusiast - Level 1

Is there a better way to block spam email?  I get many emails in the below format:


It seems if I block after the @ sign the same email will come in again, but the characters will change.  The only constant is the .info.  Is there way to wild card when something comes in from that all message no matter what they are .info do not hit my email.  I get 100's of emails a day that are spam. 

If I check all of them and click spam button I still get them.  It is never ending and I will never see the same address more than one day.  The sender will have the same contact name, but the email address will always be different ending in .info.

Tags (2)
Re: Spam blocker
Contributor - Level 1


Following is a workaround.  It's only a workaround, not a real solution.  I've copied and pasted this from a couple of messages on this board, so if the grammar or syntax isn't quite right, I apologize in advance.

There's another way to block/delete spam as it comes in.  Log into webmail and go to Settings>Email settings>filters>add new filters.  Set up a new rule that says IF To: or CC:” DOES NOT contain the email address then move to trash.

When we tried it on my wife's account, we found that she couldn't use the "Always BCC myself" setting on her iPhone and iPad.  Because she frequently uses those devices when she's away from the office and wants them on her computer for a record, it was an issue.  All of her record copies went to the spam folder.

Here's a tweak that I found that makes it more useful.  In addition to the first rule,  I added a second filter that says,

"If From Contains <email address> Then move messages to folder Inbox." 

This allows her to BCC herself. 

The glitch is if someone legitimately send her a BCC, she doesn't get it.

After trying this on my wife's account for a week, the results with this workaround aren't are as good.   She receives a fair number of smaller, "low-tech" newsletters that rely on the BCC function to send them out.  She is an elected official, so she needs to be certain that she gets these.  Because the filter blocks anything without her address in the To: or CC: lines, they are put into the Spam folder.  As I identify them, I've put in place filters for these to be sent to the Inbox, but I may run into a limit on the number of filters. 

In short, we really need the Verizon spam filter to work*.  It doesn't.  Verizon says it works, but they won't commit  any time to showing me that it does work.  This is getting tiresome.

I hope this helps a little.


*Verizon Admins, are you listening and passing this on to the team responsible for Spam Detector?  Would you please, please let them know that we have a problem that workarounds don't really solve?